Back to overview

SSL certificates expired

Feb 12, 2025 at 08:37pm UTC
Affected services
Website
Justikal IS environment
Justikal UK environment

Resolved
Feb 12, 2025 at 08:37pm UTC

Date and Time: 12 February 2025 at 08.37 GMT.
Duration: 08.37 – 13.23 GMT on 12 February 2025.

Impact: Only one user was affected i.e. Almenni lífeyrissjóðurinn. They could not deliver a declaration for a claim in an insolvency proceeding managed by a partner at ADVEL law firm through Justikal´s registered eDelivery Service as the recipient received an error message when clicking the link in the email sent from Justikal. This was due to the setup of the SSL certificate at Amazon Web Services.

Root Cause: Justikal contacted Cloudvisor which is managing all matters concerning AWS and iTO who have taken care of development work and the setup of the solution. First Cloudvisor could not understand the problem but identified that this was a connection between the SSL certificate from AWS and the DNS settings. We communicated via Slack, email and conference calls.

Root Cause:
Your request for SSL certificates has been completely resolved.

What We Did:
• Identified the resources where certificates are associated and investigated the
issue with the expiration
• Investigated and solved the issue with the DNS resolution
• Generated new certificates and replaced expired certificates to allow
encryption in transit.
• Made the transition from email-based validation certificates to DNS-based
validation certificates.
Total time spent: 2 hours 30 minutes